Private github repo cannot be added

Hi all,
I tried adding the private github repository as an external feed to my Octopus server. I generated a token with access rights on repo. I even added full access rights.
I cannot get it to work, when I try to populate the repo for some files, it pops an error that the URL is wrong.
I also tried adding the extension /api/v3 with the same results…
Unfortunately, the documentation is minimal in regards to troubleshooting so it is now a dead end.
Any help appreciated.
Thank you.

Hi @1n3l4st1c,

Thanks for getting in touch! I’m sorry to see you’re hitting this issue, and we’ll be happy to try to help get it working. :slight_smile:

Can you confirm if this is self-hosted GitHub enterprise? I’ve seen with these needing a different API endpoint to normal GitHub feeds, e.g. or

What’s the URL you’re using? Can you also send a screenshot showing the error message when you perform a Save and Test in Octopus under the feed configuration page?

I look forward to hearing back!

Best regards,


Hello Kenny,

Thank you for the reply.

I am using a private repo i made for testing purposes which is and the error i get is

I tried changing the format of the url as per your recommendations above, but still getting the same error.
Thank you.

Hi @1n3l4st1c ,

Thanks for following up! I ran through a test locally against a private repo in GitHub, and I can see this same error when using this sort of URL. In this case you’d want to use the public API endpoint ( as the URL. With the personal access token that you created which has access to the private repo, you should be able to access that repo (while preventing anonymous access).

Let me know how you go, or if you have any other questions!

Best regards,


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.