Powershell has stopped working

Hi All,

Ive been trying to install an octopus tentacle on a Windows Server 2008 R2 box for a while now via Desired State Configuration, the stage completes successfully however when I try to open the tentacle I get a ‘powershell has stopped working’ message. I then attempted to install the tentacle manually and Im getting the same error.

PowerShell is definitely installed on the system and the variable is present for the ‘Path’ system variable.

Please see attached some screenshots of the errors.





Hi Connor,

Thanks for reaching out. There is a chance that the error shown on 1.png and the message shown on 2.png are not related, so lets start solving 2.png first:

This message shows up when Octopus cant find Powershell on the Windows machine. But truth is Powershell is there 99.9% if the times, its just that the powershell executable was not properly added to the environment variables. Please check Damian’s posts on this similar ticket and follow his troubleshooting steps


Once that’s done, try to open the Octopus manager again.

Let me know how it goes


Hi Dalmiro,

Apologies for the late reply.

I have followed the steps outlined in Damian’s posts however this has not solved the issue.

Please see the attached screenshots, the first shows the PSVersionTable and the second shows that the Powershell directory is present in the PATH variable.





Hi Connor,
I can see from your screenshot that you have Powershell v5 installed. I suspect this also means you have a preview version of Windows Management Framework 5 installed?
If so, we discovered an issue with the WMF 5 preview, whereby Powershell scripts cannot be run via a Windows Service. I logged a bug with Microsoft for this.
If this is the case, the only solution is uninstalling the WMF 5 preview. We assume Microsoft will resolve this issue before the final release.

Hi Michael,

Yes you are correct, Im running the WMF5 April preview for the new DSC stuff. Hopefully MS fixes the issue soon then! Will there be any announcement as to when/if this gets fixed?



Hi Connor,

Microsoft hasn’t announced anything for this particular issue so far. Buy they do encourage users not to run this WMF5 version on Productive servers. They are pretty active with the development of WMF5, and i assume this issue should be impacting more people than just us, so i’d say it shouldn’t take that long. But that is just my opinion sadly :frowning:



WMF5 has been released to manufacturer, this is still an issue. Is there any update on fixing this or has anyone at Octopus heard from Microsoft on this issue?


Hi Glenn,

Thanks for the update. Unfortunately we haven’t heard anything back from Microsoft on this, but since it has shipped and is still an issue, we’re going to try and find a workaround for it. Here’s a ticket:

Paul Stovell