Path too long issue : how to atleast change path where the file is extracted

Hi Team,

I am having the long PATH issue , 
July 12th 2021 11:26:56Error
System.IO.PathTooLongException: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters. 

The issue because octopus is extracting the content to the root of the octpus directory , i am not able to set a custom extract location from octopus , the install to custom location feature first extracts it to the root then copy , instead of extracting to the provided path so even thats not helping


  1. is there a way to solve the path too long issue

  2. or is there a way to provide custom extract destination

Hi @praveendvd0pravu,

Thanks for getting in touch!

As detailed here packages will be extracted to the Applications folder within the Tentacle home folder.
If your tentacle home folder is different to the default $:\Octopus then you could move this folder as shown here.

The only other option would be to change the filename of your package to have fewer characters.


1 Like

@paul.calvert it would be great to have a configuration “customExtractLocation” feature where we can override this behavior (like the custominstallationlocation)

We have a user voice site where new feature suggestions can be raised and voted on. This would be a good place to raise your suggestion.

One possible workaround for you may be to use the Transfer package step instead of the deploy step and then add a script to extract the package in whichever location you require.

1 Like

Transfer the package did the trick Thanks @paul.calvert for your time

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.