Parent project is not marked as warning even if if deploy release had a warning

I have a project that has “DEPLOY A RELEASE” step inside it. This step calls another project and the project completes with a warning, but this warning does not show in the parent project. The parent project shows all steps as green.


The warning or failure state should be shown higher up the hierarchy

Hi @praveendvd0pravu,

Thanks for getting in touch! I can certainly see why you would want the parent project to show the correct status here. I ran a test to purposefully cause a success with warning in a child project, though it correctly set the same warning status on the Deploy a Release step that deployed that child project. This was in my local instance running latest (2019.13.2) - can you let me know which version you’re currently running? It might simply require an upgrade to apply some recent changes we’ve made in this area.

If you’re already running latest, could you send through some additional information to give me a deeper look into what could be causing this? The information to help would be the task logs from the deployments of both the child and parent projects, and also the deployment process JSON from both projects (these JSON files can be downloaded from the overflow menu in your project’s deployment process page as shown below).

I look forward to hearing back and getting to the bottom of this one!

Best regards,


Hi @Kenneth_Bates

just create a project say “test 1” with a powershell script step with below command

Write-Warning "WARNING!!!: Some tests have failed , please debug the failures before deploying to other enviroments."
Exit 0 

Now call the “test1” as “deploy a release” from another project say “test 2”

I am using octopus version : version 2019.12.0.LTS

Hi @praveendvd0pravu,

Thanks for following up and elaborating on that! I was able to reproduce this issue using your steps (though not exactly sure why my attempts earlier didn’t produce the same result!). Anyway this does look like something we need to fix, so I’ve raised the following bug report which you can track.

I appreciate you bringing this to our attention, and I’m sorry for the confusion and inconvenience we’ve caused with this issue. Don’t hesitate to reach out if you have any further questions or concerns going forward. :slight_smile:

Best regards,