Parallel step times out after 0 minutes when running on a single host

We have a deployment process that runs a series of different steps on different roles. All steps run custom scripts. Some of these steps are set up to run in parallel, since they don’t really depend on each other, and this works just fine. In some cases though, we have a single machine with more than one role. When we deploy to these machines, the parallel steps are usually run sequentially in the order they are defined, but not always. Sometimes, the deployment seems to choose randomly from the parallel steps, and the ones that are not initially chosen time out right away, with the following message:

Cannot start this task yet. There is already another task running that cannot be run in conjunction with any other task. Please wait...
This task waited more than 0 minutes and timed out. The other task is still running.
Script execution timed out.

As far as we know, the default timeout is 10 minutes, so we do not understand why this happens. We have even tried setting the timeout to 20 minutes, but it still times out after 0. What we do know, is that it seems to be consistent for each machine, i.e. it happens every time on specific machines, but never for other machines, despite all running the exact same deployment process. Could this be a problem with the tentacle installation on the offending machines? Are there any ways we can diagnose this problem further? The tentacle logs are rather sparse.

We are running version 3.4.14 of Octopus Deploy.

We may actually have solved this ourselves. We noticed that the latest version of Octopus is 3.8.9, so we decided to try upgrading the Octopus server, in case this would solve the problem. After upgrading the Octopus server, we were prompted to upgrade the tentacles as well, and then we noticed that our tentacles were all different versions (we saw at least 8 different versions between 3.4.14 and 3.8.9). We upgraded all tentacles to 3.8.9, and now it seems to work across all machines/tentacles.

The tentacles that previously did not work were actually the newest ones though, on version 3.8.9. So it’s probably just an issue when using different versions on the Octopus server and the tentacles.


Thanks for getting in touch and for the detailed information.

I’m glad you were able to resolve the issue yourselves. I have been able to reproduce using an Octopus Server version before 3.8.8 and Tentacles on or after version 3.8.8.

We will put out a fix to resolve: