Package not deploying when I Promote to a polling tentacle

I am trying to promote a package from my staging environment to my production environment.
The dev --> Staging promote works spiffy fine (using listening tentacles) but whenever I try to promote to the production environment I get the message: “The acquisition step will be skipped because no steps requiring packages are enabled.”

My sysadmin is requiring that we use the polling tentacle on the production server, but for some reason every configuration I try seems to always result in this message :frowning:
note: When I check the health of the server in the environments tab, it always comes back fine :slight_smile:

any guidance would be appreciated!


There are two causes for this:

  1. You don’t have any servers in your production environment that have been tagged with the role that the NuGet package step is configured to run against
  2. The NuGet package step has been configured to only run against specific environments, and production isn’t one of them

On the Process tab for your project, can you edit the deployment step, and check both the Machine Roles and Environments settings?


I convinced my sysAdmin to let me use a listening tentacle. I was able to get the server to see the tentacle (installed on port 7782) but now I am having another issue :frowning:
When I promote a package to the prod server it is just spinning in the acquire packages step, but not giving an error or actually doing anything.
I monitored the firewall and saw that it seems to be hitting ports 7782 (expected) and
unexpectedly ports 64197, 64212, 64229, 64245, 64258 ?
Thanks :slight_smile:

Hi - these are most likely TCP ephemeral ports: - let me know if you need more info.


Many thanks! I had thought they were something like that. My sysadmin let
me know about an hour ago that he had actually had a mistake in the
firewall which he has just corrected and everything is working :slight_smile:

Great, thanks for the update.