Output Variables missing on 3.4.8

Hi Octopus team,

I’m using a “Deploy to IIS” step and as step number 2 I’m trying to use this package https://library.octopusdeploy.com/step-template/actiontemplate-file-system-clean-configuration-transforms and I’m not be able to get it working as I can’t access any variable values, so far I’ve tried with these variables:

Octopus.Action[Deploy to IIS].Output.Package.InstallationDirectoryPath
Octopus.Action[Deploy to IIS].Package.CustomInstallationDirectory

I also tried to create this step as a child step of “Deploy to IIS” and still not output variables, then I tried this:


and still not lucky. I’m getting a warning of “Could not locate path…” with the same #variables instead of the values.

Do I need to setup anything to get access to this variables ?

Thank you

P.S. Would be nice to have the variable values somewhere in the popup.

Hi Ale,

Thanks for reaching out! There’s a great way to see all of the available variables during a deployment which can help you troubleshoot them. Set both OctopusPrintVariables and OctopusPrintEvaluatedVariables to True. After you create a new release and deploy, you can look in the deployment task log to see all of the variable names and values available at the beginning of each step. This is shown in more detail in our documentation.

That will give you much more information to figure out why it’s not working. If you’d like help looking through them, feel free to send the full deployment log with those variables turned on.

Kind regards,


That fixed my problem, thank you so much!