Offline Package Drop - elevated permission issue


I am just investigating the Offline Package Drop deployment target to see if it will work for us.

Within the process steps I have a couple of Powershell steps which require elevated privileges. One interacts with IIS and imports the WebAdminstration module within the script whilst the other starts the MSDTC service. However if I run the CMD as an Administrator PowerShell runs from the Windows32 directory and can’t reference the relative locations for the packages; variables etc.

I have worked around this by editing the PS1 file specifying absolute paths but this isn’t ideal as I want to generate the package set and offload it to a partner to execute.

Does anyone know of a more scalable solution for this, or is there a change planned to support this scenario?


Hi Greg,

Thanks for getting in touch! You’d need to:

  1. Run CMD.exe as an administrator
  2. CD to the folder containing the offline drop
  3. Run the .cmd file

Hope this helps,



Thanks for the quick response. That seems to have done the trick