OctopusDeploy.exe ( service failed to start after 2.6 database import

Hi Octopus team,

We’ve recently installed and configured octopus and decided to upgrade to

To get into more detail:
The initial upgrade of octopus lead to a situation where we could only use a local system or a SA account to connect to the SQL database. This was not desired due to the use of domain accounts. After troubleshooting we stumbled upon http://help.octopusdeploy.com/discussions/problems/36573-installation-issues-with-30-permissions where was an interesting option that was not shown during the installation: local or service account selection.

We figured that the previous installation might have been a local one due to the raven DB, so we uninstalled the software and performed a clean install. and the option showed.

After the second installation, the OctopusDeploy service wouldn’t start so we uninstalled the software and noticed that the service still existed under services.msc. we figured that might have to be the issue of the failing services due to older information about the actual service (2.6)

After removing the services, reboot (just to make sure) the installation worked like a charm and all seemed good.

Phase 2, data import…
We proceded with restoration of the 2.6 database and followed the steps provided by the software (select 2.6 database, use masterkey, sit back, relax and await the outcome).

The import took 12 minutes and showed: “Import complete, committing transaction”.

After the import, the tooling initializes a service cycle which resulted in an error:

Import took 00:12:51s

Detailed logging
Please look in the Octopus logs directory *****\Octopus\Logs for detailed logging information
Stopping service…
Waiting for service to stop. Current status: StopPending
Waiting for service to stop. Current status: Stopped
Service stopped

Error: Cannot start service OctopusDeploy on computer ‘.’.

Full error details are available in the log files.
At: *****\Octopus\Logs

Cannot start service OctopusDeploy on computer ‘.’.
System.InvalidOperationException: Cannot start service OctopusDeploy on computer ‘.’. —> System.ComponentModel.Win32Exception: The service did not respond to the start or control request in a timely fashion
— End of inner exception stack trace —
at System.ServiceProcess.ServiceController.Start(String[] args)
at Octopus.Shared.Startup.ConfigureServiceHelper.ConfigureService() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\ConfigureServiceHelper.cs:line 163
at Octopus.Shared.Startup.ServiceCommand.Start() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\ServiceCommand.cs:line 46
at Octopus.Shared.Startup.AbstractCommand.Octopus.Shared.Startup.ICommand.Start(String[] commandLineArguments, ICommandRuntime commandRuntime, OptionSet commonOptions) in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\AbstractCommand.cs:line 57
at Octopus.Shared.Startup.ConsoleHost.Run(Action`1 start, Action shutdown) in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\ConsoleHost.cs:line 72
at Octopus.Shared.Startup.OctopusProgram.Run() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\OctopusProgram.cs:line 86
Error: The previous command returned a non-zero exit code of: 100
Error: The command that failed was: *****\Octopus Deploy\Octopus\Octopus.Server.exe" service --instance “OctopusServer” --stop --start

We’ve tried to use the ‘local system’ account for the service, but that results in the same error.

what step’s have we missed? Is the initial database configured to use other paths / locations / useraccounts?


Thanks for reaching out. It seems like this is a bug that was introduce in 3.0.20 that prevents the service from starting, as on of the startup tasks is timing out. We believe it’ll be fixed once we fix this: https://github.com/OctopusDeploy/Issues/issues/1962

Sorry for the inconveniences


Hi Dalmiro,

Thanks for your quick reply, we (Wim and me are coworkers) cannot read the thread related to this issue since it is private (or deleted) so we cannot determine if it is the same.

Is there a way we can fix this since we cannot continue? Can we for example install version 3.0.19 (if yes where can we download it?) or are there other workarounds?

Kind regards,

Hi Tom,

That thread doesn’t have much info other than the exact same stack trace and the fact that it happened after upgrading to 3.0.20. A few possible workarounds while this issue gets fixed:

A) A user having the same issue reported that he was able to start the service by doing it from the cmd line. Please try running this command and see if the service gets(and stays) started:

"C:\Program Files\Octopus Deploy\Octopus\Octopus.Server.exe" service --instance "OctopusServer" --start

the root path of Octopus.Server.exe might change depending on where you installed it

B) Uninstall 3.0.20, then Install 3.0.19 and import the 2.6 data from it. You can download 3.0.19 from this link

We are not 100% sure these workarounds will work (though I’m very positive at least 1 of them will), so for an official fix you’re gonna have to wait until we fix that github issue.



Hi Dalmiro,

Hadn’t had time to respond earlier, we’ve uninstalled 3.0.21 and installing 3.0.19 was a bliss. After the initial installation, OctopusDepoy was automatically configured and working properly.

The only downside we’ve encountered that all the tentacles needed upgrading (like expected) re-connect to octopus, and to make them available, re-installation from within the tentacle before OctopusDeploy would recognize them as being ‘online’. All roles needed to be re-configured. All in all, everything is working now.

thanks for the support!


Hi Tom,

Thanks for the update! We are currently working on this issue and we believe we found a fix which will be released in 3.0.23 (most likely tonight) https://github.com/OctopusDeploy/Issues/issues/1962

Thanks a lot for the patience


Hi Dalmiro,

i think we stay at our current version for a while, We’re still in the development phase and don’t want to re-configure our tentacles every few days :wink:

We also have to discuss upgrades with our customer if and when we upgrade.

We’ll keep our eyes on your releases and inform the customer when it’s time to upgrade.


Hi Wim,

Upgrading to 3.0.23 should not require you to upgrade or re-configure your Tentacles. That said, I understand if you need to plan your upgrades with your customer :slight_smile: