Octopus Timing with MSBuild and Jenkins


I am building a project with Jenkins via an MS Build step, and this is passed to Octopus with the following command line


All works fine, however I’ve noticed that his creates a release that is ready for deployment BEFORE the project is fully built. This means that I have to check whether Jenkins has completely finished before I deploy to the first environment. This is particularly a problem with SQL DACPacs within the solution which error (code 1) as they aren’t fully complied and ready to be executed if deployed ‘early’.

Is the a way that I can configure Octopus to only show an available release when the solution has completely built

Many Thanks,

Hi Darren,

Thanks for getting in touch. Depending on your configuration there are a couple of options available.

If my memory is correct, that OctoPack command itself won’t create a release, so if they are automatically appearing could you confirm that you have Automatic Release Creation (ARC) enabled?

If that is the case, the release will get created as soon as the specified package gets pushed, so you want that package to be the last possible thing in your build chain.

If you can’t modify the order in the build chain then you’re best option is probably to disable ARC and add a script step to call [octo create-release](https://g.octopushq.com/OctoExeCreateRelease) (you can install octo as a CLI tool in Jenkins). You would again make this the last step, so it happens after everything else has completed.

Hope that helps and if you have any further questions about the setup just let me know.


Thanks for the quick response Shannon.

Yes ARC had been enabled on the project - I didnt even know about that feature, which is why the behavior didn’t seem to match the documentation! Makes sense now.

I will look at installing octo now and let you know if I hit any issues.

Many thanks,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.