Octopus Tentacle cannot be upgraded automaticly or removed manually

I’m having a huge issue with a Tentacle.
The tentacle cannot be upgraded nor removed. When I’m trying to automatically upgrade the tentacle, the tentacle just reports the old version number back.

Like so:
Running Tentacle version 3.4.13
October 27th 2016 15:59:07Info
Beginning upgrade
October 27th 2016 15:59:12Info
Waiting for Tentacle to shut down and restart with the new version 3.4.14…
October 27th 2016 15:59:14Info
Running Tentacle version 3.4.13
October 27th 2016 15:59:23Info
Tentacle has stopped. Waiting for it to start…
October 27th 2016 15:59:29Info
Running Tentacle version 3.4.13
October 27th 2016 15:59:35Info
Running Tentacle version 3.4.13

I’ve tried removing the Octopus Tentacle manually through the control panel, so I can reinstall it. But then the installer complains about a missing network resource.

Is there a way to completely remove a tentacle? As it is now, the tentacle is corrupt and must be reinstalled.


Added the log from this particular tentacle

OctopusTentacle.txt (62 KB)

=== Logging started: 31.10.2016 12:32:08 ===
Action start 12:32:08: INSTALL.
Action start 12:32:08: FindRelatedProducts.
Action ended 12:32:08: FindRelatedProducts. Return value 1.
Action start 12:32:08: AppSearch.
Action ended 12:32:08: AppSearch. Return value 1.
Action start 12:32:08: LaunchConditions.
Action ended 12:32:08: LaunchConditions. Return value 1.
Action start 12:32:08: ValidateProductID.
Action ended 12:32:08: ValidateProductID. Return value 1.
Action start 12:32:08: CostInitialize.
Action ended 12:32:08: CostInitialize. Return value 1.
Action start 12:32:08: FileCost.
Action ended 12:32:08: FileCost. Return value 1.
Action start 12:32:08: CostFinalize.
Action ended 12:32:08: CostFinalize. Return value 1.
Action start 12:32:08: MigrateFeatureStates.
Action ended 12:32:08: MigrateFeatureStates. Return value 1.
Action start 12:32:08: InstallValidate.
Action ended 12:32:08: InstallValidate. Return value 1.
Action start 12:32:08: InstallInitialize.
Action ended 12:32:08: InstallInitialize. Return value 1.
Action start 12:32:08: RemoveExistingProducts.
CustomAction returned actual error code 1612 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (90:68) [12:32:09:101]: Product: Octopus Deploy Tentacle – Error 1714. The older version of Octopus Deploy Tentacle cannot be removed. Contact your technical support group. System Error 1612.

Action ended 12:32:09: RemoveExistingProducts. Return value 3.
Action ended 12:32:09: INSTALL. Return value 3.
MSI (s) (90:68) [12:32:09:101]: Windows Installer installed the product. Product Name: Octopus Deploy Tentacle. Product Version: 3.4.15. Product Language: 1033. Manufacturer: Octopus Deploy Pty. Ltd… Installation success or error status: 1603.

=== Logging stopped: 31.10.2016 12:32:09 ===

Specificly I’m looking at the line:

Product: Octopus Deploy Tentacle – Error 1714. The older version of Octopus Deploy Tentacle cannot be removed. Contact your technical support group. System Error 1612.

The Tentacle is running on version 3.4.13, but I’m upgrading to 3.4.15

Hi Harald,

Thanks for getting in touch! Sorry for the delay in getting back to you. I have seen this happen for a customer. When they attempted the reinstall using the MSI and got the same screenshot as you did in your initial post, the solution ended up being using the browse button to find the previous installer. It fixed the corruption issue and allowed it to continue. I would suggest this as your first try. From some search results for resolutions to this error it does appear that it might be a registry entry level corruption.

Uninstalling Octopus does not delete anything from the c:\Octopus directory, it uninstalls the service, and deletes the registry keys. Both of these are safe to do on the Tentacle and is considered a full Tentacle uninstall.
If this above does not work for you, I am happy to help you troubleshoot this over a screenshare if that will help. Select a time from our scheduler: https://calendly.com/octopusdeploy/supportcall

Let me know how you go.

I did try browsing for the previous installer, there was actually quite a few, however it didn’t work. Complained about not being the right version, in total in tried the 5 different installers available in the Octopus folder.

I’ll have to get back to you on that screenschare, since i’m currently on a businesstrip.
Is there a description on how to remove a client in the registry, so it’s possible to reinstall the client again?


Hi Harald,

The keys can be found in HKEY_LOCAL_MACHINE\SOFTWARE\Octopus.
Older installations may have left HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Octopus\Tentacle


I’ve setup a support screenshare next week on Monday at 11 am CET +01:00.
For some reason all other days this week was full.


Hi Harald,

I have opened it up a bit which should give the end of the week more options.
See if anything is more suitable.


I’ve rescheduled it to 11:00am - Thursday, November 10, 2016 (+01:00 CET)

Is it good enough to mention the tag you are using in the emails?

Please provide a link to the support ticket where this call was requested to help us organize your call with the correct person.: [Problems #48456]

Using the #48456 as reference in the calender date.
Give me a heads up if I need to add more information :slight_smile:


Hi Harald,

That reference is fine. It is mostly to stop unsolicited requests or to match names to tickets when required. I don’t believe I should need anything further - we will mostly have to work through it on the server via screenshare.

I will send an invite link 15 minutes before the call via this email ticket.

Speak then.



Hi Harald,

Here are the details for the call:

Meet Now

Please join my meeting from your computer, tablet or smartphone.

You can also dial in using your phone.
United States : +1 (312) 757-3129

Access Code: 964-367-197

First GoToMeeting? Try a test session: http://help.citrix.com/getready

Speak soon!

Hi Vanessa.

A colleague of mine went berserk and actually removed the Octopus installation entirely (without me knowing).
So now the client runs on the most recent version. I don’t need to have a remote session with you today.


Hi Harald,

Thanks for popping into the call and letting me know I probably wouldn’t have seen this for a few more minutes.

Let us know if you need anything else.


This case can be closed as it was solved in November.