Octopus tenanted redeploy problem

our developers report a inconvenient issue with Octopus.

When someone wants to redeploy application, and project require only tenants deployments, developers need to remove tenant and add it again. Then Deploy button is enabled.

Before tenant remove:

After tenant added again:

Best regards!

Hi Piotr,

Thanks for getting in touch!

When performing the re-deploy am I correct in thinking that this is done via the overflow menu within an existing deployment?

I’ve done a quick test of this on our latest version and it does seem to enable the deploy button without any additional changes being made:

If you’re able to confirm what version you’re running I can re-test there.


Hi @paul.calvert

Thanks for your quick response.

I tested your flow on Octopus and It looks ok.
But when you go to Releases -> Specific release version you can see a redeploy buttons on each environments. When you click Redeploy, then you can observe situation described above.

Octopus version 2021.1.7316

That’s interesting, when I run the same steps you mention I kind of get the same outcome, however, I don’t see any tenants listed at all:

I’m wondering if there may be a UI bug in the build that you’re running that causes the tenant to appear in the UI but not actually be loaded, which is why the deploy button remains greyed out until you remove and re-add.

I believe that the tenant box should be blank, which is what I’m seeing.
I’ll spin up a test environment on the same build as you and see if I can reproduce the behaviour, at least then you can be sure that an upgrade would resolve it.

1 Like

I’ve just tested this on the same build and am still unable to reproduce it.

Steps taken:
Select Release

Select Redeploy

No tenants in the list as expected

I tested It once again. I first place I thought that could be browser cache. I test:

  1. Two different browsers: Chrome and Firefox - newest version.
  2. Cleared browser cache.
  3. Test in incognito mode.

And then I created new release.

For new release - See tenant, but deploy button is disabled.

For previous release - See tenant and can deploy application without re-adding tenant. It simply active and works.

I also figure out another very weird correlation. When we have two different releases:
7 and 8

Redeploy works only in release 0.120.0 for DEV, but not for rest other TEST, STAGE, PROD. When I pushed deployment in release 1.120.1-pjn-test to TEST. Then deploy button is active and works for DEV and TEST in 0.200.0.

Would I be correct in thinking that this project only has a single tenant associated with it?

If so, I believe I’ve found the problem. It looks like when a project only has a single tenant linked, Octopus will try to be helpful and automatically select that tenant whenever that deploy screen loads.
It seems that for some reason this auto-picking is causing problems with the re-deploy screen. I’m unsure why some releases work and some don’t but it should be enough for our engineers to investigate further.

In the meantime, the best workaround may be to click into the last deployment and use the re-deploy button there rather than using it on the release screen. That does look like it works everytime.


@paul.calvert as you mentioned, currently is only a single tenant associated.
Current state may lead to questions about how it works.

@paul.calvert thanks for help and have a nice weekend.


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.