Octopus; teamcity and an empty feed

Running Octopus 2.6 and Teamcity 9.1.3.
I have 2 feeds set up in the Library - one pointing to the file system and one to the PUBLIC nuget feed of teamcity. From octopus, the file system feed returns all the correct results but the teamcity feed is empty.
The feed is not empty, and when I browse it from IE, nuget.exe or Visual Studio I can see all the packages in the teamcity feed.
The is NO information in any of the log files or the event log. There are NO error messages displayed, it simply is an empty list (column headings only).
Things I have tried (in no particular order and in combination with other things):
Remove the proxy settings from octopus
Add the IE settings to octopus
Change the user octopus runs under
Restart the servers
Tried different feeds for teamcity - guest / auth etc
Added / removed the trailing ‘/’ from the feed URL

Add a feed for nuget.org (https://www.nuget.org/api/v2/) - WORKS LIKE A CHARM.

I can see the data from IE on the octopus server (while logged in as the octopus user) so there does not appear to be a proxy problem.

Does anyone have any idea what could be going on ?


Hi Luke,

Thanks for reaching out. If no errors show up with all the troubleshooting steps you already did, then my next step would be to setup a web debugger like Fiddler on the Octopus server and check what the HTTP calls to the TeamCity feed are returning.




I am experiencing the same issue.

I installed Octopus 3.4.5 and TeamCity 10.0.1. Octopus displayed an empty result when I tested the Nuget feed from TeamCity. When I downgraded to Octopus 3.3.27 that same feed worked fine.

Hi Johann,

Thanks for reaching out. It seems like you are being bitten by this open issue: https://github.com/OctopusDeploy/Issues/issues/2656

I’ve added a reference on it saying that another user (you) ran into this one to help raise its priority.

Apologies for the trouble cause by this.

Best regards,

Looks like we’re having the same issue. We’re using an Artifactory authenticated nuget feed. When I manually make a GET request to the external feed using the query - https://mycorp.artifactoryonline.com/mycorp/api/nuget/nuget-combined/Search()?$filter=IsAbsoluteLatestVersion&searchTerm=‘MyPackage’&targetFramework=‘unsupported’&includePrerelease=true&$skip=0&$top=10 - only prerelease packages are returned, even though there are higher versioned release packages within the top 10.

FYI: I tried fiddler on the Octopus service, but fiddler won’t pick up outbound https connections to my nuget feed. I even edited the OctopusServer.exe.config to use fiddler as the local default proxy, and it still didn’t seem to capture the https traffic with https enabled.

Hi @Rory,

Sorry to hear this is bugging you as well. I’ve added a comment in the github issue to increase awareness of how many users as being impacted by this.



This issue has been closed due to inactivity. If you encounter the same or a similar issue and require help, please open a new discussion (if we asked for logs or extra details in this thread, consider including them in the new thread). If you are the creator of this thread and believe it should not be closed let us know via our support email.