Octopus server not knowing enough about tentacle upgrade

Bug with octopus not knowing that tentacles have been upgraded.

After upgrading octopus server the UI tells me I have tentacles that needs to be upgraded.
I click it and see a task start, it finds my tentacles and which ones that require upgrade. All of them of course.

Then I wait. After seeing the task reporting it has run for 20 more minutes than it should, I cancel it at start it again.
Octopus now seem to reinstall all the tentacles, again, regardless of some of them being successfully upgraded on previous run.
It doesn’t upgrade all tentacles this time either, different tentacles are completed/incompleted this run. After 20 minutes I cancel and rerun. Again, it wants to upgrade all tentacles. It is seemingly random which tentacles that succeed. Different ones again. I repeat this procedure in frustration a couple of more times until I decide “octopus server doesn’t know the true status of its tentacles, they are upgraded according to the logs”. I try clicking the “check health” on the environment page and octopus then finds out that the tentacle is indeed upgraded. So solution here being that I click check health on all my tentacles, then octopus found out there were no remaining tentacles to upgrade.

I’d like to see octopus server being improved in its knowledge on what version a tentacle is running, if it requires upgrade or not.

Hi Ivar,

Thanks for getting in touch! Octopus determines whether Tentacles need upgrading based on either:

  1. Doing a health check (which by default runs every 30 minutes)
  2. After a successful upgrade, storing the version

Since your upgrade was cancelled, Octopus would have been working on old data until the next health check.

In 2.4.6 we’re making a change that might help: you’ll be able to upgrade Tentacles by environment (e.g., only update the UAT Tentacles). That release will be out in a few days.


It was cancelled because it hanged… or so we concluded after 10-20
minutes. We tried upgrading some 5-6 times before I tried clicking on
health check on every tentacle and then running the upgrade again. Which
proved unnecessary since health check showed that all tentacles actually
were upgraded :slight_smile:

Health check was very quick, whilst trying to upgrade 5-6 times and waiting
for 10-20 minutes each time was not quick, I’d suggest the tentacle upgrade
could get more reliable and faster for situations like ours, by running a
health check as part of the upgrade of tentacle.

Also, when octopus server still thought that tentacles needed to be
upgraded, and health check showed they didn’t, the actual upgrade process
did send the packages to the tentacle again and tried upgrading it and
restarting it.

Maybe this is a bug in just our installation, we have upgraded it quite a
few times now

Thank you for the follow-up. We’ll keep any eye out for anything similar - if you hit any more issues that might be related please let us know.