Octopus modifying web.config files

All of our web deployments use OctopusNotAWebSite = true. All Environment, Role, Machine, and Step are set to blank for this variable, so I’m assuming it should apply to every step for this Project, yet when Octopus deploys, it is adding encoding=”utf-8”, and changing the spacing within the file, which makes compares difficult. Is there a way to tell Octopus to not touch these files outside of the OctopusNotAWebSite variable, or do I possibly have it implemented incorrectly?

Hi Nathan,

This file is actually being modified as part of our application settings/XML transforms support:

Which version of Octopus are you using? In the 1.4 release we should have fixed the encoding=utf8 bug.


Thanks for the response. I just upgraded to 1.4 and I’m still seeing utf8 added to the file. I’m also seeing some misc spacing/carriage return changes in the xml. Is there a way to disable this entirely?

It looks like I may have had some stale data, or a tentacle that wasn’t upgraded as it appears to be working fine now. Thanks Paul!