Octopus Manager reset to welcome page

I was configuring bindings to my instance of Octopus Deploy this morning when disaster struck. The hard drive was full and the save operation failed. My OctopusServer.config file was rendered blank and Octopus Manager displayed an XML error. I quickly restored it from last night’s backup, but now when I run Octopus Manager it takes me to the get started splash screen. The web interface loads fine and all my configuration is there - but when I load Octopus Manager I can’t seem to figure out how to administer my instance.

Is there a way to get it to recognise that there is an installed instance of Octopus?

I wanted to back up my Master Key just in case - when I run Octopus.Server.exe show-master-key I get:

Loading plugins from: C:\Program Files\Octopus Deploy\Octopus\BuiltInExtensions
Loading BuiltIn extension: AzureAD (
Loading BuiltIn extension: Directory Services (
Loading BuiltIn extension: GoogleApps (
Loading BuiltIn extension: Guest (
Loading BuiltIn extension: UsernamePassword (
Octopus Deploy: Server version 3.5.0 (3.5.0+Branch.master.Sha.258670f18ba1abd5d35e423a3527085d67a6728e)
Octopus Master Key:
The default instance of OctopusServer has not been created. Either pass --instance INSTANCENAME when invoking this command, or run the setup wizard.

So I guess my default instance has become corrupt? I don’t have a backup of my Master Key (of course I didn’t copy it down) and I would not like to lose my configuration!

Hi Hamish,

Thanks for getting in touch. It sounds like you may have lost a registry entry! You may be able to get everything back and running yet.

I am going to find the registry keys on my VM and get back to you ASAP.

Best regards,

Hi Hamish,

Would you be able to confirm that you have the following registry entry?


String Value:
Name = ConfigurationFilePath
Data = C:\Octopus\OctopusServer.config

The Data string should point to the location of your OctopuServer.config file. The example I have given you is from a default installation on my VM.

Let me know how you go.

Best regards,

Hi Daniel,
I was missing the HKEY_LOCAL_MACHINE/SOFTWARE/Octopus/OctopusServer/OctopusServer/ key and string. I added them (same values) and it worked perfectly. Thank you very much for the prompt response.

I have backed up my master key to a safe place now!


Hi Hamish,

No worries at all! We are always happy to help! :slight_smile:

Best regards,