Octopus hangs in the middle bash test script on Linux Centos 6.6; but the script runs well from the Linux's terminal

Hello guys,

This is my situation: I use Octopus 3.2.7 to deploy application on Centos 6.6. The deployment of NuGet package to CentOS is good. However when I run a test script, the Octopus hangs in the middle of test script.

Here is the script I write for the step in Octopus:
cd /home/piuser/install/test/devops/logapi
sh ./logapi_regt_core_telemetry_devops.sh localhost

Octopus hangs when running logapi_regt_core_telemetry_devops.sh.

To test if there is any problem with logapi_regt_core_telemetry_devops.sh, I logged in to the Linux server by using the user I use to run the step from Octopus . I did it by several ways:

  1. I checked and confirmed the above script has been successfully transited to target server under .octopus\OctopusServer\Work\20160201192757-7889. I run “sh script.sh” and I can see logapi_regt_core_telemetry_devops.sh runs well until finished.
    Or 2) I go to /home/piuser/install/test/devops/logapi and run “sh ./logapi_regt_core_telemetry_devops.sh localhost”. logapi_regt_core_telemetry_devops.sh runs well to finish.

So it seems there is something wrong with Octopus on this.

Did you guys encounter such problems before? Any advise?

Thanks a lot,


Hi Edward,

Thanks for getting in touch! Our Script console allows you to test scripts to see how they will behave when running them through a deployment.
To help you figure out what is going wrong here we would need to see what you are doing with your script.
Are you able to provide it for us?


Figured it out – some command is “terminal based” using /dev/urandom which caused script to hang. It is fixed after using alternative to avoid using /dev.

Hi Edward,

Thanks for letting me know!