Octopus deployment Crash

we’re at present getting the following error in live

Can some one please analyse the the issue

Hi @binh.au,

Thanks for getting in touch!

There isn’t a lot of information to go on within the screenshot but the error suggests that the problem may be related to access permissions or a disk problem. Possibly even a corrupted install of the tentacle and calamari.

Is this error occurring for a single target or for multiple targets?
If it is a single target, has this deployment target worked successfully in the past?
If so, have any changes been made to this machine since the last successful deployment?


We are deploying to 3 linux servers using ssh connection.

We have 9 releases (all using the same Octopus project) deploying to different tenants.
All 9 release deployment goes to the same 3 servers.

5 out of 9 deployment failed with the same error.

actually, looking at the 5 failed deployment. they are all referencing the same servers. The others are different servers.
I think, let me double check

yep, the failure is only on 3 server that is specific the 5 deployment.
Last successful deployment run on these servers was back in March 26th.

I’m not aware of any changes to the servers.
I’m looking at the disk space where octopus home exists in and it’s got 21% usage.

Do you have any suggestion on how I can analyse this issue?

The file being referenced Octopus.Calamari.DeploymentJournal contains a list of previous deployments to that target. It is possible that this file has become corrupted somehow and is failing to open.
You could try taking a copy of the file on one of the server and then deleting it from the original location which will force it to be re-created during the next deployment. If that works then repeat the same action for the other affected servers.

If that doesn’t work, another possibility is that something on the machine is locking or preventing access to that file. We have seen security software cause similar problems in the past, so, placing this folder into an exclusion list for any security software running on these targets may help.

octopus use a ssh connection to the linux server
Where would is file on the server?

I believe the location would be /home/octopus/.octopus/OctopusServer/DeploymentJournal.xml

Hi, we’ve found the root cause. a software on the server has blown up /tmp. Thank you for getting back so soon.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.