Octopus deploy for Jira app not installing

Hi support,

We are using Octopus deploy in our Company and want to integrate JIRA with octopus. However when installing it runs into an error and the app is not installed. The reply from JIRA support is redirecting me to you an dI hope you can help.

Below is the mail with more details from JIRA support.

Thanks in advance

Hi Arie,

Thank you for contacting Atlassian Support.

With regards to the issue that you have raised, I was able to reproduce the issue while trying to install Octopus Deploy plugin for Jira and found below error

com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonInstallRejectedException: Error contacting remote application 400:[Bad Request]:

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonCallbackHandler.requestInstallCallback(ConnectAddonCallbackHandler.java:154)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonCallbackHandler.requestInstallCallback(ConnectAddonCallbackHandler.java:96)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonManager.makeSyncCallbackIfRequired(ConnectAddonManager.java:486)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonManager.installConnectAddon(ConnectAddonManager.java:175)

at com.atlassian.plugin.connect.plugin.lifecycle.ConnectAddonInstaller.install(ConnectAddonInstaller.java:226)

Error contacting remote application at ‘https://jiraconnectapp.octopus.com/jira/events/installed?user_key=557057%3A6817257c-76c2-4e46-8ffb-97c37540e354&user_account_id=557057%3A6817257c-76c2-4e46-8ffb-97c37540e354’ 400:[Bad Request]:

I did another test by installing a different addon ScriptRunner for Jira and the addon was installed successfully(I’ve removed it as it just for testing purposes)

Based on my test and the error from the logs, I suggest you contact the addon vendor directly as it seems the issue is from their end. You can raise a support ticket to the directly from here:

Hope that helps.


Hi Azmir,

I just tried to install the Octopus plugin into my own Jira Cloud instance and it succeeded for me.

Can you try to install the Octopus plugin from the Atlassian marketplace again and see if it works for you now?

Thank you and best regards,

Hi Henrik,

Azmir from atlassian gave me those logs in my previous post. I just tried to install again and still the same error, the app is not installing.

Can you help me out here?

Thanks in advance!

Hi Arie,

I’ve made some changes, can you please try it again now.

Thank you and best regards,

Hi Henrik,

It’s installing now, thanks for the quick support :slight_smile:

Best regards,

Hi Arie,

Great to hear that you were able to install the plugin now.

Thanks for letting me know.



I am also having issues setting up the Jira integration. I have installed the application in Jira multiple times and performed the get started process, but it always returns to a get started stage or uninstall. Any help would be appreciated. Thanks


I’m also having this issue. I’m not really sure if the Octopus Plugin actually gets installed. Clicking the “Get Started” button on Jira Apps Management page for the Octopus Plugin regenerates a new key to use. Are there any other configuration settings? There’s not much on our end to verify it’s been installed or configured correctly.

Hi Daniel,

As long as you don’t see an error after you’ve gone through the Get Started process, it should be installed correctly. I’ve raised the issue with it looking like the configuration wasn’t successful with the team and we’ll look at making that experience better.

Once you’ve got the plugin configured in your Jira Cloud instance you need to follow our package metadata docs and Jira Cloud docs to get deployment info pushed to your Jira Cloud instance.

I hope that helps.

Thank you and best regards,


I think it is installed, but not configured. I just went through the Get Started actions again and when completed it takes me to the search for apps in the Jira Marketplace with the Octopus Deploy add-on selected. When I go back to manage the app it shows Get Started and Uninstall for the options. I have configured it within the Octopus Deploy settings page, but I don’t see the additional section showing up on our Jira tickets.

Any help would be appreciated. Thanks


Hi Dan,

Have you followed our guide to get started with package metadata and work items in Octopus. Without the package metadata being pushed to Octopus we don’t have any reference to Jira issues to push deployment info to.

Thank you,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.