Octopus Deploy does not appear to upgrade, even after the upgrade installer is finished

I am running of Octopus Deploy.

Last week I got a message that I’m using an unsupported RC build so I tried upgrading to 2.1; the installer finished, I started the service, the left corner of the web interface still shows I am running 2.0.9. I decided to wait until a new version is released, thinking that might help…

Today, I tried upgrading to 2.2.1. The installer finished (including the 2.2 specific ‘checking for powershell 2.0…’ dialog), I started the service from the Octopus , the left corner of the web interface still shows that I am running 2.0.9. Thoughts?


Can you:

  1. Use Octopus Manager to Stop the Octopus windows service
  2. Close Octopus Manager
  3. Go to Add/Remove programs and uninstall Octopus
  4. Install the 2.1.3 MSI again
  5. When Octopus Manager appears, use the Reinstall button for the Octopus windows service (instead of start)
  6. Reload the page in your browser to see if 2.1.3 installed properly this time