Octopus Deploy - Configuration SMTP test email not working

Hello Team,

I am receiving test smtp email in my mailbox in-spite of I am getting success message. I have tried with default port 25 and 587 but it didn’t work.

Please find below raw log for troubleshooting -

Task ID: ServerTasks-22835
Task status: Success
Task queued: Friday, February 10, 2017 4:56 AM
Task started: Friday, February 10, 2017 4:56 AM
Task duration: 4 seconds
Server version: 3.3.2+Branch.master.Sha.ba2859229aae7aaca25a803313513ec7e3f4178a

                | Success: Send test email

04:56:27 Verbose | SMTP host: smtp.sendgrid.net
04:56:27 Verbose | SMTP port: 587
04:56:27 Verbose | SSL enabled: True
04:56:27 Verbose | SMTP login: (removed)
04:56:27 Verbose | SMTP password: (removed)
04:56:27 Verbose | From: sanket.phating@accenture.com
04:56:27 Verbose | To: sanket.phating@accenture.com
04:56:27 Info | Sending test email…
04:56:31 Info | Email sent.

Best Regards,

sorry one typo…

not receiving email


Thanks for reaching out! Sorry but I’m a bit confused by that last reply :(. Did you make it work or not?

I see you are from Accenture also. Have you tried reaching out your internal devops team (Ian, Thadd, Mauro, etc) already? They’ve configured tons of Octopus instances and I’m sure they know how to get this setup in Accenture’s network.


HI Granas,

Sorry for the typo :frowning:

I am not receiving smtp test email. Have you check my configuration? Is it ok or do I need to change something ?

Best Regards,

Hi Sanket,

No worries!

The configuration does look OK from that log, but keep in mind that I’m not aware of your server’s address or port.

What I would personally do is first try to see if Octopus is sending emails correctly using a fake smtp server. I usually use Papercut (https://papercut.codeplex.com/) for this. You just need to install it on the Octopus Server VM, and then register the SMTP server in Octopus as Localhost and the port that you set up in Papercut.

If the above works works, then the next step would be to look at the (real) SMTP server logs and see if your emails are actually arriving there or not.

Best regards,

Hello Dalmiro,

It works, thanks :slight_smile:

It was not working earlier, when I was using the same from and to email address. Now I have changed the from address and it started working.

Thank you for your help. You can close this case. Cheers !

Best Regards,

Glad to hear it’s working!