Octopus Builtin deployment - Success when it should have failed


We are using an Octopus builtin deployment process for some of our config files. We have run this deployment 100’s of times and we have not had an issue. Today we had an issue where the files weren’t being copied and overwritten into the
location we specified.

The deployment showed as successful but infact it wasn’t. I then had a deeper look in the tasklog and found this message.

Retry #254 on copy ‘File Path’. Exception: The process cannot access the file ‘File Path’ because it is being used by another process.

As you can see it tried well over 200 times and then proceeded to say that the deployment was successful but infact it should have failed.

The task log said this.

“Copied 1 files” but it hadn’t copied to the correct location.

I then logged onto the server and tried to do a manual copy with the file that had been uploaded to the server. It also failed with the same message.

“because it is being used by another process.”

I spent some time investigating and something on our network had this file open. I have now corrected this however it’s VERY concerning that the deployment showed successful when it actually wasn’t.

Please could you shed some light on whether there is a bug in Octopus for this.

We need to know asap please guys.


Hi Lance,

Thanks for reaching out. Could you please share us the deployment log so we can get a better understanding of what happened?




I have been told by Rob this.

"If you update to Octopus 3.1.7 or newer, it should fail the build as expected. "

Thanks for getting back to me though.