Octopus 3.2 NuGet Package index not building after migration from 2.6

Hi Support,

We’ve somewhat successfully imported out Octopus 2.6 Server to a fresh 3.2 box, however we’re having some trouble import our NuGet Package library. Initally we got the first ~240 fairly quickly, but since then (around 12 hours) we’ve only gotten to 251 (most of which appear to be new packages that have been imported). Taking a look at the octopus logs we’re getting the same error over and over referring to a package that isnt in our repository (‘E:\octopus\Packages\Op.UpdateService\Op.UpdateService.’.) from ~2014.

We’re not sure why the log is referring to this over and over, but it does as it attempts to read each package into the index. We tried restoring it to the folder, but then we just get a different error for duplicateid.

Have attached a partial log post octopus server restart for your perusal.


Thomas Taege

OctopusServer.txt (2 MB)

Ok, we’ve blown the database table’s contents away and have started a staged approach to importing packages, everything looks good so far. Currently imported 3.5k packages, so much better than before.

All ~6000 of our packages have now imported successfully. We have to assume there was something odd that had occured with the indexing process as part of our migration.

Please consider this issue resolved.