I have a question regarding setting RunOctoPack in msbuild.

Can I not set the setting with in the projects by in the project file as opposed to using the command line to compile my projects?

I’ve tried it on a windows service and it worked great (true under ), but it doesn’t work in the web apps I’ve tried so far.

Hi Zeddy,

Thanks for reaching out. We didn’t build Octopack with that use case in mind, so I don’t think any of us have even tried it. Can you send me your csproj file with the command line arguments added and working for your windows service?

Also please send me a build log that shows a successful Octopack run for your windows service, and the failing one for your webapp.


Hi Dalmiro,

The proj file looks like this:

<?xml version="1.0" encoding="utf-8"?> ShowAllFiles true

I have OctoPack installed as a package for the Windows Service.

I’m currently testing Octopus deployment tools and going forward, we’ll be using a dedicated build/CI server which will (hopefully) package everything up and push it to so I may not need to worry about this, but I want to understand it ground upwards.

Thank you


So setting <RunOctoPack>true</RunOctoPack> should be enough to get this working.

  • How are you building your application while having this value in your csproj file? Straight from VisualStudio? Using a build server? Something like Psake or Cake calling MSBuild directly? I’d like to know so I can reproduce this myself.

  • You say this is working for your Windows Service project, but not for webapps. Can you confirm your project is a Web Application and not a WebSite? https://msdn.microsoft.com/en-us/library/dd547590(v=vs.110).aspx?f=255&MSPPError=-2147217396

  • Finally, if the above answer was Web Application, do you see the same results if you create a vanilla project, just add Octopack and try to compile it?


Hi Dalmiro,

It’s fine.

We’ll be using TeamCity for CI and that takes care of this so I am satisfied with what we have.

Thank you