Octopack installation issue


We are facing issue while installing octopack 3.0.45, we are getting error as "The element ‘metadata’ in namespace ‘http://schemas.microsoft.com/packaging/2012/06/nuspec.xsd’ has invalid child element ‘developmentDependency’ in namespace ‘http://schemas.microsoft.com/packaging/2012/06/nuspec.xsd’. List of possible elements expected: ‘language, copyright, frameworkAssemblies, releaseNotes, dependencies, tags, references, summary, description’ in namespace ‘http://schemas.microsoft.com/packaging/2012/06/nuspec.xsd’. ". Even I tried to search the previous version of octopack from Nuget Package Manager in VS 2012 but its finding latest version of octopack only. So can you please suggest how to resolve this issue. We are facing the same issue since one week

Kindly help on this

Please reply to mail id

Thanks & Regards,

Hi Rajababu,

Thanks for getting in touch. Hopefully we can resolve this issue and get you up and running. Can you tell me what version of NuGet you’re running? I did a bit of research and I found some information indicating that the error occurs with older versions of NuGet. If you’re not running the latest version, I’d suggest upgrading as it will likely help. Also, can you tell me if this occurs with a brand new solution/project?

Let me know how you go.


Hi Rob,

Thanks for your reply

We were trying to install latest version of octopack only(3.0.45) still we
are getting same error, this is not yet resolved.

I am attaching error screenshot with this mail, Kindly help on this.

please let me know which version of octopack we can install successfully.

Thanks & Regards,

Hi Rajababu,

Rob Pearson is on vacation and I will take over this ticket for you. We recently added the developmentDependency to OctoPack to fix a compatibility issue with NuGet 3.0 in Visual Studio 2015.

You have two options from here:

  1. Upgrade the version of the NuGet Package Manager in your installation of Visual Studio 2012 to anything > NuGet v2.8 - developmentDependency was added in NuGet 2.8
  2. Install an older version of OctoPack that didn’t use this NuGet feature: https://www.nuget.org/packages/OctoPack/3.0.33

I would strongly recommend using option #1 and upgrading your NuGet Package Manager in Visual Studio since there have been many beneficial additions to OctoPack between 3.0.33 and 3.0.45.

Hope that helps!

Hi Mike,

Thanks for you reply

I have upgraded Nuget Package Manager in Visual studio 2012, Successfully
installed octopack after upgradation.

Thanks for your valuable suggestion