NullReferenceException after Moving Octopus Server - Re-install doesn't fix

Hi, this is very similar to this thread:, so I tried to “move” the octopus home directory using the script in here:

There was a problem in that it couldn’t move some of the files (E.g. the raven db). So anyhow it got itself into a bit of a state. I tried to manually move the files and that didn’t seem to resolve it. So I figured I have backups and my encryption key, I will just uninstall it and reinstall it all.

However after removing all traces of octopus server, and reinstalling (even to a different location) I still get this error after installation when it first tries to fire up Octopus Manager:

System.NullReferenceException: Object reference not set to an instance of an object.
   at Octopus.Tools.OctopusConfiguration.OctopusManagerModel.Reload(ApplicationInstanceRecord applicationInstance) in y:\work\refs\heads\master\source\Octopus.Tools\OctopusConfiguration\OctopusManagerModel.cs:line 173
   at Octopus.Tools.OctopusConfiguration.OctopusManagerView.<Refresh>b__0() in y:\work\refs\heads\master\source\Octopus.Tools\OctopusConfiguration\OctopusManagerView.xaml.cs:line 104
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)

Any ideas?

Hi Andrew,

Thanks for getting in touch! Very sorry about the delay in getting back to you.
The error is because the Octopus Server cannot find the config file. The part of the script where it deletes and creates a new instance with the config file is the important part (and something that was missing from the directions on the documentation page that the first user had an issue with). To fix this it may be a case of finding the config file path, and re-running that part of the script. It references a registry key that was very possibly not deleted when you removed all traces of Octopus Server.

Hope that helps!