Nuget package upload exception

I’m using octo.exe (Octopus Deploy Command Line Tool, version 4.13.4).

First “pack” to create a large (1.5GB) nupkg, and then “push”. I receive an exception trying to upload to the built-in feed on Octopus server running 3.3.11.

I see similar reports going back in time, but no resolution. Also, I didn’t notice any fixes in subsequent Release Notes. Is there a workaround?

Hi there,

Thanks for reaching out!

  • Does it throw that error right away, or does it take a few seconds/minutes to do so?
  • Do you get the same error with a smaller package?
  • Have you tried using the --timeout parameter of octo.exe push to increase the timeout?

In Octopus 3.4 we updated the Nuget binaries we use in the Octopus back end to Nuget 3.4 (numbers are coincidence). I remember this helped lots of users with a few nuget-related errors, and if I’m not wrong it also helped improve the performance when pushing big packages such as yours. So if none of the above questions ring any bells, I’d suggest you to upgrade your Octopus server to the latest version and try again on it.


Also, that error message on your screenshot if from the web portal, so I’d be interested in seeing the error from your console when you run Octo.exe push