New file in package not getting added to IIS site

I’m having an issue with a deploy step which updates an IIS website via a nuget package. If I add a file to the site and during our build it gets added into the nuget package (which I’ve confirmed that it does) the corresponding deploy process will not add the file to the destination folder. If I purge the directory first, it works and the file shows up, but I’d rather not do this because there are several folders I’d like to keep in the directory. Any ideas what is going on here or if I’m missing something?


Hi Nick,

Thanks for contacting us. Have you checked on your build output that Octopus is actually deploying the new package version and that it is not skipping it for some reason (like “package already deployed”)? If the pre-file-package and the post-file-package have the same version, by default Octopus will not deploy it.

Try to check the box that says “Force deployment of packages that are already installed” and “Re-download packages from the NuGet server” and re-deploy on a server where you still haven’t the added file.

Let us know how it goes.


Forgot to add the screenshot of the checkboxes location :slight_smile:

That worked like a charm! Thanks for your speedy response!

Oh also I didn’t have a checkbox that said “force deployment of packages already installed” but checking the other one worked.