New deployment/installation broken

I was on version and I just tried to install the latest version Octopus. It “installs” fine through the MSI installer but when the Octopus Deployment Manager opens and I click “Start” for the service I get a very small error window and the service won’t start.

I uninstalled 1066. I was able to get 1020 to install and startup the service and everything appears to be working fine on the lastest version.

This is the error message

A fatal exception occurred
System.InvalidOperationException: Cannot start service OctopusDeploy on computer ‘.’. —> System.ComponentModel.Win32Exception: The system cannot find the file specified
— End of inner exception stack trace —
at System.ServiceProcess.ServiceController.Start(String[] args)
at Octopus.Shared.Startup.ServiceCommand.Start() in c:\TeamCity\buildAgent\work\1116bd9da9e239fd\source\Octopus.Shared\Startup\ServiceCommand.cs:line 188
at Octopus.Shared.Startup.ConsoleHost.Run(Action`1 start, Action shutdown) in c:\TeamCity\buildAgent\work\1116bd9da9e239fd\source\Octopus.Shared\Startup\ConsoleHost.cs:line 36

Error: The previous command returned a non-zero exit code of: 100
Error: The command that failed was: “C:\Program Files (x86)\Octopus Deploy\Octopus\Octopus.Server.exe” service --instance “OctopusServer” --start

Hi - sorry about the hassle; we left some notes on the downloads page about this but unfortunately they were too easy to miss. To reconfigure the service path, run:

Octopus.Server.exe service --stop
Octopus.Server.exe service --reconfigure --start


I get this…

Command '--start' is not supported

Just tried upgrading from to

In my Octopus Manager it tells me the service is not installed, but the reinstall link is greyed out. How do I reinstall the service?

Cheers Patrick

Read the Important Notes here…

Sorry - typo in the instructions above, the second command should have been:

Octopus.Server.exe service --reconfigure --start

Note the “service” part missing from the first version.

You can run:

Octopus.Server.exe service --install --start

if the service is not installed for whatever reason. We’ll update the Reinstall command so that it is always available and handles this case.