Missing Nuget packages after upgrade from 2.6 to 3.0 (Have followed instructions)

Hi, I’ve setup V3 on a new server to migrate our 2.6 installation across.

The data import seems to have worked ok (apart from a missing project image) but copying the Nuget packages from the old server to the new server as per the instructions has not worked. I have restarted the Octopus service several times and it doesn’t seem to be indexing these packages (I see nothing listed on the Library > Packages screen).

I’m certain I’ve copied them into the right Packages folder on the new server. Is there anything else I can try to resolve this issue?


Update: Turns out I was being impatient. The packages turned up in the list after about 10 minutes. If this is expected behaviour it might be worth updating the upgrade documentation to mention that there may be a delay - it’s easy to assume it hasn’t worked.

The upgrade has run smoothly so far apart from this.

Hi Chris,

Thanks for the feedback. Turns out the package index on restart runs in the background so you do not have to wait for it, but for many packages it could take a while - which is what you found.
I have updated the documentation to mention this. Thanks for letting us know!