Missing Logos


I recently moved my octopus deploy to a new server (copying the artifacts) and since then the Logos are missing off the projects. The projects were created a while ago and i have since lost the logos. The issue is there seems to be no way to reset the logo as described here: https://help.octopusdeploy.com/discussions/problems/47206-dashboard-missing-images-show-broken-link



Hi Scott,

Thanks for getting in touch,

I’m sorry to hear you are experiencing this issue, I understand this behavior can be frustrating.

When you upload images they are copied to the folder “Artifact” as you outlined, as part of the Octopus.Server.Exe command line tool you can specify the location of the moved artifact folder as shown below;

Octopus.Server.exe path --instance="Octopus" --artifacts C:\OctopusData\Artifacts

Alternatively, whilst the new UI doesn’t retain the functionality to reset the image, you can instead replace app# with oldportal# in the Octopus URL to load Octopus using the V3 and access this function for this purpose. You should then be able to simply replace oldportal# with app# respectively to return to the V4 UI.

I hope this helps!

Please let me know if you require any further assistance or clarification :slight_smile:

Kind Regards,


Hi Reece,

That worked and i was able to reset the logo however it did throw up some more questions!
On the old portal it was missing on the dashboard but the logo was visible once you clicked into the project.
The URL on the dashboard was api/projects/Projects-41/logo?cb=Projects-41 where as on the project it was api/projects/Projects-41/logo?cb=Projects-41?cb=1528184069. When i added the ?cb=1528184069 bit to the url on the new dashboard it worked.

Anyway, i was able to go into each project, save the image and re upload it into the new portal.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.