Manual intervention and failrue step

Hi there,

we found a strange behavior of the process steps. We have a manual intervention step and depending on its result we would like to run a finish upgrade or a rollback steps. The rollback step is configured to run if a previous step is failed. But if the user clicks on the abort button the rollback step won’t run. It is intended or just a bug?

If we configure the rollback step to run always it is executed in case of abortion. But in this case there is no output variable from the manual intervention step which indicates the result (Ok or Abort). So we cannot do any workaround right now. If the above mentioned behavior is not a bug then this variable would be essential to handle the abortion.


Hi Attila,

Thanks for getting in touch. I have tried to reproduce the problem by creating three steps:

  1. Manual Intervention
  2. Run on Failure
  3. Always run

When I ran the deployment and selected “Abort” both steps 2 and 3 ran. However I did notice step 2 did not show on the overview (I will raise an issue for that), but it was there in the log.

Could you please send me the task log or the steps to reproduce? You can mark this ticket as private if you are sharing sensitive information.

Robert W

Hi Robert,

You are absolutlely right. It is not shown on the summary tab but it is listed on the task log view. I attached the screenshots.

Thank you!

Hi Attila,

Good to know. Here is a link to the issue.

Robert W