Issues Creating release with Octo.exe

We have upgrade our version to 2.0. We have a custom script on our build server which will call octo.exe to create a new release and deploy the release to the specific environment. This has been working fine except for one project. The “Acquire packages” step works but on the first deployment of a package it fails with the error “The package CSISServeWS was not found on this machine.” when it fails I click “Try Again” and it fails with the same error. But When I create a new release manually through the Website GUI and release it, the deployment succeeds. What would change between the two packaged in Octopus. Again I want to note this has been working for all other projects I have tried so far.

Here is the successful downloading of the package:

Downloading packages
15:24:43Info Making a list of packages to download
15:25:03Info All packages have been downloaded
Download package CSISServeWS from NuGet feed: CSIS
15:24:43Info Downloading NuGet package CSISServeWS from feed: '\devbuildvm01\NuGet\Octopus\CSIS’
Upload package to https://devwebvm5002:10933/
15:24:44Info Uploading CSISServeWS. (4.14 MB) to SQ-DEVWEBVM5002-8AD60292
15:24:52Info Package CSISServeWS successfully uploaded to tentacle SQ-DEVWEBVM5002-8AD60292