Issue deploying a release to a single tenant in an environment with multiple tenants

Hi, after creating a release for our main project (a web application) we are trying to deploy to just one of our development environments rather than all the dev tenants.
At the top of the deployment page, we select the Dev environment and then select a single tenant. Then when we click the Advanced link we can see that all tenants in the Dev environment are selected for deployment. We then have to choose a sub-selection of just the one we want.
This duplication is annoying so not sure if we have configured something wrong (we have tried as many configuration options as we could think of). It seems the select Environment and select tenants does and “AND” rather than treating the selected tenant as the required list of targets.

We have 5 dev tenants, each containing two machines (one web server and one DB server) with a Web or DB role applied appropriately.
When we select the Dev environment and select the first tenant we do see that all are listed in the Preview section… see attached image (deployissue.jpg)
Each tenant in the Dev environment has a tag of “Internal Dev”, we tried removing this to no avail.
We also have channels meaning we want to restrict what pre-release packages can be restricted to a specific environment.

Any clues as to what we are doing wrong would be appreciated.

Been thinking about it and It seems what we are missing is a link between tenants and machines… which is likely the cause!

Hi Richard,

Could you let me know what version of Octopus you are running?

We fixed this issue in 3.4.11 on the deployment screen where machines that weren’t part of the deployment still showed as if they would be deployed to. (But if you did deploy it would only deploy to the Tenant that matched the selected criteria), so it could be that you’ve hit this issue.

Thank you,

We have been running 3.6.0 since last week. We were on 3.5 when I posted this message though.

Hi Richard,

How have you mapped the machines to your Tenants? I just setup the scenario you outlined in your initial post and I’m seeing the correct behaviour in my setup so there must be something missing in your configuration.

This is what I did:

  1. Added my Tenants (Dev1, Dev2, Dev3)
  2. Added my Tenant Machines (Dev1Web, Dev2Web, Dev3Web) to my Development environment
  3. Mapped each machine to its respective Tenant in the Tenants selector
  4. Mapped my Tenants to my project and Development environment
  5. Created a new release
  6. Selected Dev1 to be deployed to
  7. Viewed the deploy preview and only the machined mapped to Dev1 was highlighted (the others were greyed out)

Let me know if this helps you find the missing configuration.

Thank you,