Invalid version string error


I created a Release for one of the Tentacles. When I edited the Release entry, I changed the version from “0.0.1” to “VRTVW 0.0.1”. When I view the Release, it returns an error and I am also unable to edit the entry to revert to the old value.


Hi Basil,

Thanks for getting in touch! We recently fixed this issue in a recent release. You can now view and delete bad release numbers.
If you are not able to upgrade you will have to delete the release from the DB itself.

Let me know how you go.

Hi Vanessa,

Thank you for the response. We’re currently using Octopus Deploy What is the release version that has the fix?
Can you also provide me a link or the steps to delete the release from the DB?



I also tried using the approach in this link (, however, the Octo.exe version is not compatible with our Octopus server. Is my assumption correct that this is the DB delete approach?


Hi Basil,

Yeah the fix was part of 2.5.5.
The delete-releases command still works. Octo.exe is a separate install from Octopus
You can download it here: if it is out of date. However the issue remains with the latest octo.exe it throws the error of a bad release number.

So this leaves you with actually opening up the RavenDB browser "Octopus Manager -> Browse RavenDB"
Under Documents you can find Releases. We then need to know which ID to delete.
Under Audit back in the Configuration section of Octopus Server you can mouseover the release number for when the release was created - it should give a number such as Release-126
Then that row can be deleted from the Raven DB browser.

As you can see a bit convoluted to do manually, thus why it was fixed in 2.5.5.

Hi Vanessa,

This technique of deleting the offending release worked for us. Thanks so much!


Hi Vanessa,

Wouldnt it be safer to add a validation to that field before the users hit save? I just got the same issue as Ian and had to go to Raven to Fix it up.



Hi Dalmiro,

That was part of the 2.5.5 fix (see screenshot)