Invalid master key going from 3.3.2 to 3.16.2

Getting ready to upgrade from 3.3.2 to 3.16.2 and on my test system its telling me the master key is invalid. I pulled the key off the 332 server and even tried the powershell cmd to pull the key here with no luck. Do we need to go to another version as a step before going all the way up?

Hi Tim,

Thanks for getting in touch! The version of Octopus should not have any issues with the master key. Generally problems with master key are around inconsistent backups, badly formatted files or incorrectly setting up a new machine.

Just to be clear, any upgrade requires running the installer and upgrading over the top of your existing version. I am reading your ticket a few ways, and there is no need to upgrade to another version between 3.3.2 to 3.16.2, the 3.3.2 database cannot be installed into a 3.16.2 instance.

Could you let me know the steps you took to move your instance onto your test environment? Did you copy the folders over? If the answer is yes, this is probably where the problem lays. Our certificate and master key are linked to machines, and you cannot copy over configuration files onto a machine and have the master key correctly work. We have some documentation on how to move your Octopus Server. While I understand that you are not moving it, you are attempting to copy it, and majority of the steps are the same to get the instance working correctly.

Let me know what you think and if you have any questions.

Hi Vanessa,
Sorry i was being stupid, i was trying to restore the 3.3.2 database and connect directly from 3.16.2. Yes installing 3.3.2 and then upgrading the box solved my troubles. Enjoying the new version, thanks