Installation :: Unable to start the service


I was trying to install Octopus Deploy server in one of our production server.
While configuring below is the error message i got.

2015-08-24 09:36:48.0792 1 INFO Service credentials set
2015-08-24 09:36:48.1260 1 ERROR ===============================================================================
2015-08-24 09:36:48.1260 1 FATAL Cannot start service OctopusDeploy on computer ‘.’.
System.InvalidOperationException: Cannot start service OctopusDeploy on computer ‘.’. —> System.ComponentModel.Win32Exception: The service did not start due to a logon failure
— End of inner exception stack trace —
at System.ServiceProcess.ServiceController.Start(String[] args)
at Octopus.Shared.Startup.ConfigureServiceHelper.ConfigureService() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\ConfigureServiceHelper.cs:line 163
at Octopus.Shared.Startup.ServiceCommand.Start() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\ServiceCommand.cs:line 46
at Octopus.Shared.Startup.AbstractCommand.Octopus.Shared.Startup.ICommand.Start(String[] commandLineArguments, ICommandRuntime commandRuntime, OptionSet commonOptions) in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\AbstractCommand.cs:line 57
at Octopus.Shared.Startup.ConsoleHost.Run(Action`1 start, Action shutdown) in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\ConsoleHost.cs:line 82
at Octopus.Shared.Startup.OctopusProgram.Run() in Y:\work\refs\heads\master\source\Octopus.Shared\Startup\OctopusProgram.cs:line 75
2015-08-24 09:36:49.1934 1 INFO Deregistered OctopusServer from the database
2015-08-24 09:36:49.2793 1 INFO Deleted instance: OctopusServer

I suspect this error is because of user permission issue.
Please let me know if user permission is the issue.

And also please let me know if once i got the required permission will just restarting the service will complete the configuration of Octopus



Thanks for reaching out. The user is definitely the issue: The service did not start due to a logon failure . Changing the user on the service and restarting it should do.



Hi Dalmiro,

The issue was while installing I had chosen “Custom Domine Account” and the
custom user don’t have permission to start the service.
Now when I try to change the service account to “Local account” while
configuring Octopus its ask for master key of database which I don’t have
as the configuration in my previous attempt was not successful.
I don’t have access to the DB to drop the database and recreate one.
Is there any other way to use the existing database without providing the
master key or is there any other way to get the master key (maybe by
querying any table).
Please let me know…



You need to change the service login account from:

Services.msc -> “OctopusDeploy” -> (right click) Properties -> Login

Make sure this account has access to the SQL database.



I uninstalled one of my working Octopus Deploy server and tried re-installing it again… faced the same issue as Pratheesh stated… Prior to Master key step, when I was asked for the DB, selected TFS_Configuration which was the same I’ve used in my previous Octopus installation.

I tried the above suggestion quoted by Dalmiro, but no luck.

At last I tried creating a new DB in my SQL server which I referenced instead of TFS_Configuration then it did not ask for the master key at all… and my installation went through successfully.

Hi Dhana,

Thanks for letting us know of your solution.