Incompatible runner: OctopusDeploy

I’m trying to get TeamCity and Octopus working together - specifically trying to get TeamCity to push a release zip to Octopus, but i’m having not luck at all.

Both TeamCity and my 1 agent is running on Ubuntu in their own VM. Octopus is running in VM running Windows Server 2016. I installed the TeamCity plugin (twice, as i tried a fix with uploading through the TC admin page) and i installed the .NET Core and made sure dotnet is working, but all i get when trying to run my build is:

Incompatible runner: OctopusDeploy: Push packages

What am i doing wrong? Does this not work on Linux or did i just do something wrong?

Hi Jacob,

Thanks for getting in touch and sorry you’re seeing this problem. This should absolutely work on Linux.

I’m assuming you have .NET Core 2 installed? It looks like in .NET Core 2, the output of running dotnet at the command line changed, and our detection of it no longer works, so when TeamCity looks for agents that can run our plugin, it can’t find any. I’ve fixed this check and pushed out a new version of the plugin, which you can download here: Check that you see v4.15.9 in the plugin list after updating and restarting TeamCity.

Unfortunately this isn’t quite enough. It seems that .NET Core 2 can’t run apps that target v1 of the framework, Octo (which is the app the plugin runs) requires It may be sufficient to install only that, I installed the dotnet-dev-1.1.0 package on Ubuntu 14.04, which also installed that, and that got me up and running.

I hope that helps. We should be cleaning some of this up shortly as the release of .NET Core 2 makes the cross platform story quite a bit nicer.


I’m absolutely blown away by the provided support. I installed the new version of the plugin as well as the dotnet-dev-1.1.0 package and everything was working perfectly in minutes.

Thanks you very much, Mark!

I am having the same issue and installed dotnet core 2. I am very new to shell and all of this so I don’t know how to install dotnet-dev-1.1.0. I am running a RHEL7 vm and all i got is the commandline. Google was not very helpful. Any guidance on where to look is greatly appreaciated!

I found all the information i needed here:

instead of dotnet-dev-1.1.0-preview1-005051 i just installed dotnet-dev-1.1.0

Thank you!

I finally solved it.

Glad you got up and running Marcus. Thanks for helping out Jacob.