'IIS Application - Create' step template omitting part of physical path

The ‘IIS Application - Create’ step template is only picking up the first part of any physical path specified, for example if in the template parameters I specify:

D:\Program Files\Acme Co\ComponentName.Service\

the step will only set the site to:
D:\Program Files\Acme Co

We originally noticed this using variables, but it’s the same if you provide a hardcoded path as well. The inbuilt ‘deploy nuget package’ step with a ‘custom directory’ feature enabled happily creates and copies files here, but we’re using vroots so need the ‘IIS App-Create’ step.

Has anyone else noticed this or found a fix?

Sounds like a bug in that script, I’ll take a look at it and quote the paths in there.

For the record, it still seems to do it using:


as the path too

Hi Damian - were you able to recreate and resolve this issue?

Fixed it - it would seem that when I set ‘PhysicalPath’ in a variable set, it was overwritten by a variable by the same name inside the step template. As soon as I used a different variable name inside the variable set, problem solved.

Hi Rob

That’s a good pickup!
We spent some time this week looking at why it wasn’t escaping. Variable scoping would explain it!

Sorry you hit that, we should make that clearer.


No probs – are there any other reserved variable names I need to watch out for?