I get AccessDenied when trying to add new Polling Tentacle


I choose “Polling Tentacle” / “64-bit/x64 installer”, and get this:

AccessDenied Access Denied 240CA33D681954C4 oUicpwxSvbs/WSeQ07vdwdpCAmzIfXOT9eE3ESkgGTxbIQSQjK4mAwMC3N0toOqwBKxZ8XOd8pc=


Thank you for contacting Octopus Deploy support in regards to this query,

Sorry to hear you are experiencing this issue, can I ask for some additional information in order to help resolve this? If you can please reply to the below questions this will greatly assist the investigation.

  1. Which version of Tentacle are you attempting to install?

  2. Which Server Version is being used for the Tentacle Agent installation?

  3. Are you running the installation as a Standard User or Administrator User?

  4. In which area of the Installation Wizard are you seeing this error occur? (Can you attach a screenshot for a visual aid?)

I look forward to hearing back from you regarding this, I greatly appreciate your patience and understanding during this time.

If you require further assistance or clarification please let me know :slight_smile:

Kind Regards,


Hi Reece,

Here is my attempt to answer your questions:

  1. Not sure how to find out that.

  2. I dont know, here is the screenshot from Diagnostics / Server Logs

  3. My user is a member of “Octopus Administrators” team which has access to
    all environments and has a role of “System administrator”

  4. All I did was: Environmens / Add deployment target / Polling Tentacle /
    64-bit/x86 installer - and that’s when I gat the error

[image: Obraz w treści 6]

[image: Obraz w treści 7]

[image: Obraz w treści 8]

Now I can see that the operation fails at attempt to download a tentacle
msi from the download server:

Trying to open: http://download.octopusdeploy.com/ in a browser gives the
same result with “Access Denied”

And here are some HTTP details:

  1. Request URL:

    2. Request Method:
    3. Status Code:
    403 Forbidden
    4. Remote Address:
    5. Referrer Policy:

    1. Response Headersview source
    2. CF-Cache-Status:
    3. CF-RAY:
    4. Connection:
    5. Content-Encoding:
    6. Content-Type:
    7. Date:
      Tue, 07 Nov 2017 07:13:42 GMT
    8. Server:
    9. Transfer-Encoding:
    10. Vary:
    11. Via:
      1.1 023afde1c2c62910e220b4efedc28c2f.cloudfront.net (CloudFront)
    12. X-Amz-Cf-Id:
    13. X-Cache:
      Error from cloudfront
    14. Request Headersview source
    15. Accept:

    2. Accept-Encoding:
    gzip, deflate
    3. Accept-Language:
    4. Connection:
    5. Cookie:
    _ga=GA1.2.225056843.1493107112; _gid=GA1.2.3083829.1509956376;
    6. Host:
    7. Upgrade-Insecure-Requests:
    8. User-Agent:
    Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML,
    like Gecko) Chrome/61.0.3163.100 Safari/537.36

Missing cookie, token?

regards, Przemek S.


Thank you for getting back to me regarding this query,

Based on the information provided in your latest response, it seems there is a connectivity issue between your Server and the S3 Servers.

Are you able to test to see if you can access S3? If you are unable to do this than this would be the reason you are experiencing this ‘Access Denied’ error when attempting to download the MSI installer.

If you require further assistance or clarification please let me know :slight_smile:

Kind Regards,



I assume that download.octopusdeploy.com is your S3 Server. This is where
our istance of octopusdeploy is trying to get the installer for a tentacle
from. I get the same error if I try to connect to the server itself or if I
try to download the specific *.msi file from the browser:

[image: Obraz w treści 3]

[image: Obraz w treści 2]

Tried with Fiddler, got* HTTP/1.1 403 Forbidden*:

[image: Obraz w treści 5]

Pinging is ok:

[image: Obraz w treści 4]

regards, Przemek

Hi Przemek,

Thank you for getting back to me,

I’ve looked further into this, and it seems the version of Tentacle that you are attempting to download via Octopus has actually been removed. As a result, this is why you are experiencing this error. This issue was fixed in 3.16.0 and reported at the following link which you can reference here.


You can download the most recent version of the Tentacle Agent here , you can use this later version of Tentacle without needing to update your current Octopus Server version.

If you require any further assistance please let me know :slight_smile:

Kind Regards,