Failed to migrate data from one server to another

Hi Octopus Team,

When I tried to export/import from server 3.3.20 to another server 3.3.20, it works fine.
However when I tried to export/import from server 3.7.3 to another server 3.7.3, i got many of following errors

Octopus.Shared.ControlledFailureException: Did not find Event ‘Events-####’, likely a key collision error

Please help. Thanks in advance.

Hi Jian,

I’m sorry to hear you’re having problems with Importing\Exporting your data.

Could you please attach the log file from your migration? This should be located in your Octopus Server logs directory, named OctopusMigrator.*.

We will certainly investigate.


Hi Michael,

I managed to resolve the issues, and got it working on our QA environment.
However when I do the same to another Octopus server in a production environment, I got following error

The target principal name is incorrect. Cannot generate SSPI context.

Hi Jian,

That error is indicating your Octopus Service cannot authenticate against the SQL Server instance.

Are you running the Octopus Service as LocalSystem (the default) or a domain account? Is SQL Server installed on the same machine, or remotely?

Is it possible you are running the Octopus Service as LocalSystem and trying to connect to a remote SQL Server instance?

It is quite detailed, but this page may provide some useful information.

Hi Michael,

I am running the Octopus service as a domain account (same domain as the SQL Server, and this account has “sa” permission to the Octopus database).

The SQL server is installed on another machine.

I just tried to use localSystem, also got the same error as using the domain account.

One thing to note though, before trying to perform the importing operation. the domain account was able to start the Octopus service without any issue, after I tried to import the data into the octopus which I got the error “The target principal name is incorrect. Cannot generate SSPI context”, for some reason, the domain account has failed to start the octopus service since then. Why this could break?


Hi Michael,

We end up resolved the issue, it was due to the password had been changed for the octopus service account, everything is working fine after we manually restart the SQL service.