Fail is step skipped because no machines were found


If in a release a step has no machines to run on it will currently be skipped and marked as succeeded. For us not deploying is seen as a failure and must be avoided. Is there a way or option with which we can make such steps fail the step and thus the deployment?

Hi Kelvin,
Thanks for getting in touch! I’m sorry to hear that you are seeing unexpected results when you deploy a project to an environment with no available targets.

One option which comes to mind could be to set the Skip Deployment Targets option to do not skip deployment targets if they are or become unavailable

To make this change, you can set it at the Project level by navigating to a project, then selecting Settings.

I look forward to hearing if this helps!

Kind regards,

Hi Lawrence,

Thank you for your answer.
The Skip Deployment Target setting has already been set to “do not skip”.
By taking a closer look I see the option “Prevent this step from being skipped when deploying” on step level which sounds like the solution, but the problem is seems this has to be done on step basis, which is tedious work when you have a lot of steps like we do. Is there a (global project) option which does this for every step in a project?

Thanks in advance!

Hi Kelvin,
Thanks for keeping in touch and I’m sorry for the long delay in getting back to you on this. Also you are correct, I just realised that my initial solution doesn’t fully satisfy your requirements.

Unfortunately there’s no global setting for preventing a step from being skipped at the project level. I believe one option could be to set each of the steps programmatically. To achieve this you could use the Octopus Server API to iterate through each of your projects, setting the flag for IsRequired to True, which is the corresponding setting for the option in the Octopus Portal “Prevent this step from being skipped when deploying”.

I look forward to hearing from you if you have any other questions here.

Kind regards,