Error when uploading package



Octopus errors when uploading a file to the tentacle. This happened after 20ish minutes, This package never timed out on Octopus 1.6, has something changed to make the upload slower?

Error -

Download package Website_CaseManager from NuGet feed: TM NuGet 12:58:49
Info Downloading NuGet package Website_CaseManager from feed: 'http://nuget/'
Upload package to 12:59:26
Info Uploading Website_CaseManager. (416.91 MB) to SQ-TEST-WEB01-4744D60B13:22:29

Fatal The actor FileSender-AVE-f7m9ayT1@SQ-TM-DEPLOY01-BD3DBE6D cannot handle failure Octopus.Shared.FileTransfer.SendNextChunkReply
System.InvalidOperationException: The actor FileSender-AVE-f7m9ayT1@SQ-TM-DEPLOY01-BD3DBE6D cannot handle failure Octopus.Shared.FileTransfer.SendNextChunkReply
at Pipefish.Actor.OnHandleFailedTyped[TBody](Message deliveryFailure, Message failedMessage, Error error) in c:\TeamCity\buildAgent\work\cf0b1f41263b24b9\source\Pipefish\Actor.cs:line 169

In terms of performance version 1.6 deployed the project in 11 minutes, the identical project / packages in v2 failed to download all files within 20ish minutes.

Any ideas why this could be?

Hi Graham,

Thanks for getting in touch. Uploads in 2.0 may be slightly slower because of the new communications stack (not as optimised yet for file transfers as the old WCF one).

However we shouldn’t time out anywhere near 20 minutes. Can you please give me a rough idea of the package size?

The complete logs from the Octopus server and one of the target tentacles (should be in C:\Octopus\Logs on both machines) would help greatly with getting to the bottom of this. My email username at our domain is ‘nblumhardt’ - feel free to post them directly if you’d prefer not to attach them to this thread.

Thanks again for the help.

Its 416.91 MB. I have sent you a test email, if you could respond and I will send you the logs.

We’re seeing a similar issue, we’re having a 42m package, and distribution from octopus to 2 tentacles (over a local network) takes around 4-5 minutes, where it actually used to be 10-12 seconds in octopus 1.6.

When I change the nodes to download each nuget package individually from the nuget feed, package download returns to 10-15 seconds.

Oh and we just uninstalled the old 1.6 tentacle as this service was only disabled, but this didn’t solve the problem. It did solve the problem of the event log being flooded with this message:

2014-01-07 14:02:23.9318 ERROR Unhandled error when processing request from client
System.IO.IOException: The handshake failed due to an unexpected packet format.
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
at Pipefish.Transport.SecureTcp.Server.SecureTcpServer.ExecuteRequest(TcpClient client) in c:\TeamCity\buildAgent\work\cf0b1f41263b24b9\source\Pipefish.Transport.SecureTcp\Server\SecureTcpServer.cs:line 109

Thanks for the extra info Weibe.

Graham, I’ve replied to your email, please let me know if it didn’t make it through.


I was getting a similar error message, but with a 2.5MB package. In my case, the issue was that I was running the Octopus tentacle as a domain user (instead of Local System), and that domain user didn’t have the proper permissions.

Our problems seem to be caused by McAfee on the server, jumping to 100% CPU when the Octopus tentacles are doing their work, grinding everything to a halt…

2.4.2. fixed this issue for me.

Excellent, glad to hear that, thanks Graham.