Error Deploying Kubernetes Container with Secret Volume

Running Octopus version v2019.3.0. I’ve also reviewed the release notes for 2019.3.1 and 2019.4.0 but I don’t see a fix for this issue.


When using the Deploy Kubernetes Container step with the Secret feature enabled and configured, saving the step fails with an error when adding a Secret Volume that references the secret created as part of this step.

Steps to Reproduce:

  1. Add a Deploy Kubernetes Container step.
  2. Configure the step to deploy a container.
  3. Enable the “Secret” feature.
  4. Add a Volume that is configured as “Reference the secret created as part of this step”.
  5. Add an item to the secret with a name and value.
  6. Hit save and the error message “The secret feature must not be left blank or disabled because a volume has been configured to reference it.” appears.

Expected Results:

The configuration saves successfully.

Hi Jeff,

You’re quite right. Thank you for the excellent report. It seems that was a bug we introduced recently.

I have created an issue, and we have committed a fix. This should be available in a release next week.

We apologize for the inconvenience.


Excellent, thank you!