Dynamic azure web app target error: "No package has been staged"

I was able to resolve this, see the next posts for the remaining problem.

Immedately after sending the question, I realized that the dynamic targets have appeared in infrastructure and the web app is actually being deployed. So I believe things are working now, as I was also able to remove the scope/role MyApp.Proxy from the cloud region and with that, the error is gone. Good times!

Why do I need to give a the role for a Azure Cloud Region deployment target? The roles are needed for the Web App deployment targets, but Azure Cloud Region role is not used for anything, since it is only involved in deploy an ARM template step?

When deploying to a new dynamically created region, I still get this error during the first deployment:

The step failed: Activity Deploy cNeuro.Proxy on myappdev-proxy-app failed
with error 'No package has been staged'. 

After web app deployment targets have been created during the first deployment, second deployment works. How can I make the dynamic targets work during the first deployment, when the resource group is created?


Thanks for getting in touch! I have some ideas that should help you get this working. The first thing that comes to mind is to try a health check step. You can place this step in your deployment following the creation of the deployment targets. This should make the targets available for Octopus to deploy the packages to.

If this option does not work to resolve this issue, then you may have to look into splitting the project into two separate projects. One project to create the deployment targets, perform a health check, then run a deploy a release step to initiate the deployment of the second project which contains the web app packages.

Would you be able to let me know if either of these options help?

If you have any further questions or thoughts here, please don’t hesitate to let me know.

Best regards,

Thanks, it works now! Adding a health check step helped. I configured it to “Perform a connection-only test” and “Include new deployment targets in the deployment”.


Thanks for the update! I’m glad to hear this is working for you now.

Please don’t hesitate to get in touch at any time.

Best regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.