Docker on windows 2016 - cannot set the port mappings


I’ve enabled windows containers support in octopus and i’ve managed to get it working except the port at present I can figure out how to pass in -p 8000:80 successfully.

I’ve tried typing into the Port Mapping fields with the values literally but got the same error as attached. I then assumed I needed to be a variable, but I get the same error.

would be great to get some feedback on this ASAP as i’m assessing octopus (which we’ve used for years) versus AWS ECR (which is very complex).


octopus-docker-failure.txt (13 KB)

Hi Mick,
I was able to easily reproduce this error and it looks like Docker on Windows does not support the documented arguments for the docker run command. I have logged an issue to track this work and investigate if there are any other broken parameters.

In the meantime you may be able to get around this limitation by adding your port bindings to the Args field near the bottom of this step. (e.g --publish #{TIMEOUT_PORT} #{CONTAINER_PORT}) and this will be included in the command invoked by Octopus.

Keep an eye on the above ticket, and let me know if you run into any further issues.