Docker install -- cannot login


I installed the docker variation (:latest tag) under a Linux host, and upon install completion, I cannot login.
I have tried:

  • Using the default “admin” : “Passw0rd123” (aka leave blank ADMIN_USERNAME and ADMIN_PASSWORD)
  • Using custom credentials, without special characters in either (same env vars)
  • Manually executing /Octopus/Octopus.Server admin --username user --password pass
    (as a post-installation attempt to change pass after the fact. Same problem)

I can confirm the user exists in the [Users] sql db table. And it has a hash specified in json props of JSON column.
The login fails on direct access on 8080 port of non-ssl http login page.

The backend error log only shows ONE entry:
POST 0HM7KF5TNPKH5:00000001 by <anonymous>
That’s it. One log entry per sign in attempt.

The front end reports visually: “Invalid Username or Password”, and Chrome console reports t he following 400 code response:
“ErrorMessage”: “There was a problem with your request.”,
“Errors”: [
“Invalid username or password.”
“ParsedHelpLinks”: []

Help would be appreciated. It is currently completely unusable.


Thanks for the report - we are currently investigating.



1 Like

Hi @bdurand,

I apologise, this one completely slipped through the cracks. How did you go with getting to the bottom of this?

Looking at what you’ve tried, all of the things you have tried should have worked.

If you are still having trouble with this can you please provide the following info:

What version of octopus was installed with the “latest” tag?
Can you provide your docker-compose file? Feel free to redact passwords but I’ll also turn this ticket into a personal message so you can share the information without worrying about the information.

Can you also provide the following Logs from your Docker image:


I will likely also need the config file and the Server Log file - the location of both should be in the final few lines of the above listed file.

Likely it will be:

I can provide a secure location to upload these files if you wish.

Again, sorry about the delay.



No worries on time all good, I think I have an idea as to the cause but it’s a guess.
Instead of using the built-in SQL node bound to the network for the set of instances, I used my own. Which is a slightly older version of sql server. Although the data installed fine, perhaps a character set difference or something.
Will attempt redeploy this week, and inform of resultant. & will get you those log files here in this thread, thank you!

Hi @bdurand

Thanks for the update. I’ll be here if you get stuck along the way. If you do discover the issue - please let us know as well!

Good luck.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.