Docker deamon not running on Ubuntu dynamic worker

As of today, every time I deploy a release that runs inside a container it is failing because docker is not running on the worker. I have tried to deploy releases from multiple different projects.

On one project, I have tried several reruns and also deleting and recreating the release. Every time the deployment is run on the same Ubuntu (default) dynamic worker - 21-04-23-0747-ncu02.

Please note that I am able to pull the image in question locally, so the issue is not with the container registry.

Assuming it’s just the one worker that is poorly, please can the worker be destroyed.


Hi @dgard1981

Thanks for reaching out! Sorry to hear that you’ve hit this issue.

I’ve destroyed the worker so please try running the deployment again and let me know if this resolves it for you.


Hi Stuart,

We are now seeing a new worker, but the same issue persists. I will drop you a PM with the logs and some other (maybe) useful information.


To close this off, after PM’ing Stuart the issue has been resolved. While the root cause has not yet been identified, killing off several workers seemed to do the trick.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.