Difficulty installing Octopus - can't get to http://localhost/Octopus

Hi there,

I’ve installed Octopus on my local box but haven’t been able to navigate to http://localhost/Octopus. In following the Getting Started guide (http://help.octopusdeploy.com/kb/getting-started/installing-octopus-and-tentacles), I didn’t have any uncertainties until the very last step, about enabling ASP.NET v4.0 in the ISAPI extensions - attached is a screenshot of the end result of my efforts with respect to the ISAPI extensions. Also in the screenshot is the console of my Octopus.Server, which I’m not sure how to interpret.

I’m certain that the Octopus database exists and is configured+saved in my “Server Tools” app; and that the Octopus service is running. I’m not sure what I’m missing.

If you have any suggestions, would you please let me know?

Thanks for reading.


I’m not sure I’m setting up the db correctly. When I try to access the Octopus Portal on my localhost, I’m getting a SqlException for a failed login. The strange thing is, the username it fails under isn’t the username I specified in the Octopus Config connection string. The username it fails under is instead the name of my server.

I’ve set up the SQL db Octopus, and Octopus Config tells me it’s happy with my connection string (clicking 'Save and Test" tells me: “Connection successful.”). Additionally, my db Octopus gives permissions to the username I’ve specified in my connection string, as well as “NT AUTHORITY\NETWORK SERVICE” (added the latter while trying to figure out this problem).

Please let me know if you have suggestions. Thanks in advance.

This thread can be closed.

Problems resolved thanks to db config and toggling DTC properties.


Hi Lisa,

Sorry for not getting back to you sooner, I’m glad you found a solution. The Octopus installation tool needs some work to setup IIS to operate under the context of a custom user with database permissions, and that’s on my backlog!