Deployment issues between old 2.5 and new 3.x Octopus

Hi I have just created a new virtual machine and installed both latest Team City and also latest Octopus on it. I have got Teamcity working and also configured Octopus but I have run into a problem. The way we worked with the old version of Octopus was to use the deployment target dropdown to select the environment(s) to deploy a release to - this worked well for us. However in the latest version ‘LifeCycles’ are getting in the way of this deployment strategy. On the new system of Octopus how can I achieve the older - non lifecycles style of deployment?

Hi Clive,

Thanks for getting in touch! While we do things a little different now, you are still able to configure your Lifecycle in order to display the dropdown box. You can do this by adding all of your environments to the same phase in your Lifecycle. (See phase.jpg)

This will show you a dropdown list of environments when selecting Deploy after creating a release. (see dropdown.jpg)

Hope that helps! Let me know if you run into any issues here or have any further questions. :slight_smile:

Best regards,